Deprecated: Function set_magic_quotes_runtime() is deprecated in /var/www/web1643/html/phpBB3/common.php on line 106
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3526: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3528: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3529: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3530: Cannot modify header information - headers already sent by (output started at /common.php:106)
ppsGrid.de • Thema anzeigen - .NET Framework 3.5 SP1

.NET Framework 3.5 SP1

Hier werden Fragen zur Programmierung des ppsGrids...

.NET Framework 3.5 SP1

Beitragvon eoe am 29.09.2009, 07:55

Hallo Torsten,

anbei ein weiteres kleines Problem. Ich bin vor kurzem auf das .Net Framework 3.5 SP1 umgestiegen. Jetzt habe ich allerdings im visuellen Editor immer Probleme, eine Grid-Control auf meinen Controls zu platzieren. Das ableiten eines Steuerelements von der Standard-Grid-Klasse funktioniert noch Klasse, sobald ich dieses Control dann weiter integrieren (anwenden) möchte, gibt es aber immer die folgende Fehlermeldung:

System.Runtime.SerializationException: Der Typ „System.ComponentModel.Component“ in der Assembly „System, Version = 2.0.0.0,…“ ist als nicht serialisierbar gekennzeichnet.

Als Workaround erstelle ich die entsprechenden Controls händisch im Code und nicht mit dem Designer. Der Designer wäre aber doch schöner :-)

Erik
eoe
 
Beiträge: 38
Registriert: 17.04.2007, 15:02
Wohnort: Oedheim

Re: .NET Framework 3.5 SP1

Beitragvon torsten am 30.09.2009, 08:04

Hallo Erik
Welche IDE verwendest du denn bzw. welche IDE verwendet das ".NET Framework 3.5 SP1" ?

Das ppsGrid benötigt (immer noch) die .Net-Version 1.0/1.1
(Ich hatte mal versucht, auf höhere Versionen umzusteigen, bekam dafür aber Schimpfe :-) )

Getestet habe ich es mit vs2005 unter .Net 2.0, alles darüber hinaus ist ungetestet,
versionsspezifische Fehlermeldungen gibt es von anderen Anwendern bisher nicht.
Gruß Torsten
torsten
Site Admin
 
Beiträge: 92
Registriert: 02.05.2006, 09:04
Wohnort: Bremen

Re: .NET Framework 3.5 SP1

Beitragvon eoe am 01.10.2009, 07:52

Hi Torsten,

ich arbeite in der Regel mit dem VS 2008. Wie gesagt, wenn ich die Controls im Code einbaue, kann ich den Rest des Steuerelements weiter grafisch bearbeiten. Kritisch wird es nur dann, wenn man das Grid direkt in den Designer einbindet.

Erik
eoe
 
Beiträge: 38
Registriert: 17.04.2007, 15:02
Wohnort: Oedheim

Re: .NET Framework 3.5 SP1

Beitragvon torsten am 01.10.2009, 08:01

Moin moin
1. Frage: Gibt es das Problem nur unter vs2008 ?
2. Frage: Gibt es das Problem auch bei einem neuen (Test-)Projekt ?
3. Frage: Welche vs2008-Version nutzt du ?
4. Frage: Hast du mit vs2008 auch andere .Net-Versionen genutzt ?
5. Frage: Gab es bei dir das Problem auch mit anderen vs-Versionen ?

Fragen über Fragen, muss mir wohl vs2008-Express runterladen...
Gruß Torsten
torsten
Site Admin
 
Beiträge: 92
Registriert: 02.05.2006, 09:04
Wohnort: Bremen


Zurück zu Fragen zur Programmierung

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron